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This is the September 2019 release of the TRIMBLE GEDO 
NovaTrack User Manual, English language version v2.0.1.  
It applies to the TRIMBLE GEDO NovaTrack software and 
GEDO CE 2.0 track measurement systems. 
 

Copyrights 
All information listed in this manual is the intellectual 
property of Trimble Railway GmbH. All rights are reserved. 
You may not use, access, copy, store, display, create, sell, 
modify, publish, distribute, or allow any of third party access 
to, any graphics, content, information or data in this manual 
without Trimble Railway GmbH written consent and may 
only use such information for the care and operation of your 
Product.. 
 

Contacting Trimble Track Survey & Scanning Support 
If you cannot find the information you need in this manual, 
submit an inquiry to Trimble Track Survey & Scanning 
Support. 
1.  Go to www.trimble-railway.com/en/contact/trimble-
railway-gmbh/  
2.  Enter contact information and provide enquiry with 
detail information 
3.  Click the Submit link 
 
Trimble Railway GmbH 
Korbacherstraße 15 
97353 Wiesentheid 
Tel +49 9383 9732-0 
Email info@trimble-railway.com 
www.timble-railway.com 
 

Legal Notices 
© 2007-2017, Trimble Navigation Limited.  
All rights reserved. Trimble, the Globe & Triangle logo are 
trademarks of Trimble Navigation Limited, registered in the 
United States and in other countries. 
The Bluetooth word mark and logos are owned by the 
Bluetooth SIG, Inc. and any use of such marks by Trimble 
Navigation Limited is under license. 
Microsoft, Windows, and ActiveSync are either registered 
trademarks or trademarks of Microsoft Corporation in the 
United States and/or other countries. 
 
All other trademarks are the property of their respective 
owners. 
 

Disclaimer 
Trimble Navigation Limited reserves the right to alter the 
specification of this product and/or the content of this 
manual without advance notification. 
This publication describes the state of this product at the 
time of its publication, and may not reflect the product at all 
times in the future. 
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 General information 

 

 Introduction  

 Updating this manual 

 Related documentation 
 

This manual is a user reference guide for end users who have completed training courses and have been 
certified at Trimble Track Survey & Scanning Training Centers or at designated Dealer Training facilities. It 
describes how to manipulate and operate track measurement data using Trimble GEDO track systems. 

 Introduction  

 

Training on the GEDO NovaTrack software is required, in order to understand measurement data 
processing workflows and  make correct calculation result interpretation. 

 

The technical documentation and the recommendations within are intended solely as a complement to the 
skills acquired through training. They can never replace theoretical and practical training provided in 
accordance with good practice. If the operator does not feel capable of providing personnel with this 
training, Trimble Track Survey & Scanning or designated Dealer organizations can be consulted concerning 
the training program. 

The training must cover the explanation of the different functions of the material, instructions for its use 
and maintenance, and the safety rules to respect, as well as practical exercises. 

 

 Updating this manual 

Photographs, illustrations, specifications and other details in this manual were up to date when the manual 
was released. Any changes that may be needed will be issued as supplementary or replacement pages, via a 
Product Bulletin, other service information, or as a new revision to this manual. 
 

 Related documentation 

You can download the latest version of this manual, as well as all Product Bulletins, User Guides, and any 
Declaration of Conformity relevant to the TRIMBLE GEDO CE 2.0 trolley or TRIMBLE GEDO NovaTrack 
product group from the Trimble Track Survey & Scanning Support site (requires active Extended Warranty 
software agreement and user registration). The files are in Adobe Portable Document Format (PDF). 
 

Important! 

Read all relevant Product Bulletins before you start operating TRIMBLE GEDO NovaTrack software product. 
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To download an operating instruction for Trimble GEDO NovaTrack software products: 

1. Go to the Trimble Track Survey & Scanning Support website at http://www.trimble-
railway.com/download  

2. Enter your username and password and then click Login. 

3. In the folder structure, select Subject and required Product 

4. Select the item that you want to download. 
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 About the software 

 

GEDO NovaTrack is a software tool for optimization, adjustment and alignment calculation of existing 
railway lines.  

Track re-alignment tasks are placing high demands on the precision of the alignment calculation. Whilst 
within the track re-alignment phase, GEDO NovaTrack software continuously streams horizontal and 
vertical offsets between existing track and newly calculated alignment. 

Trimble GEDO NovaTrack software enables the automatic reverse calculation of alignment elements in an 
absolute coordinate system based on track survey data from the Trimble GEDO systems. In this way, the 
alignment elements with optimal parameters and absolute positions are estimated to best fit the current 
track position. This software functionality enables seamless design alignment data delivery within project 
areas where track design information is absent or out of date.  

GEDO NovaTrack – other areas of use: 

 Adjustment of existing alignments. 

 Analyzing the deviation between two alignments. 

 Calculation of horizontal and vertical distances between alignment and fixed objects. 

 Identifying chainage information for structural elements along the track alignment, for example, 
catenary masts. 

 

Overview of TRIMBLE GEDO NovaTrack  

 

GEDO NovaTrack analyses rail measured points taken from the GEDO CE track measurement systems and 
generates optimal positions for both horizontal and vertical alignments through theses points. The quality 
of the calculated alignment is compared to the measured points and illustrated using offset diagrams. In 
the alignment editing phase, these diagrams are used for reviewing the alignment elements. 

GEDO NovaTrack uses the .GDT file format (centreline) to import measured track data.  Additionally, the 
software supports other measurement data formats, from ASCII file formats (column separated data). 

The calculation accuracy is dependent on the distances between the measured points and the 
measurement accuracy. The minimum required distance between points dependent on the geometry of 
the railway track and its quality. Small radii and complicated transitions between alignment elements with 
many consecutive curves requires shorter distances between the measured points.  

A distance of 3.0 m between measured points will generally give a good result with most tracks. If the 
geometry is less complicated, the distance between points can be extended up to 5.0 - 10.0 m. Further 
increased distances between points is not recommended. 

 

GEDO NovaTrack is using following abbreviations for horizontal and vertical alignment elements: 

S - Long fall gradient. Slope of the vertical alignment element in per-mil 

SE - End of Slope. Marks the transition between gradient and vertical curve element. 

HBP - High Break Point. Vertical intersection point where the slope decreases. 

LBP - Vertical Intersection Point. IP where the slope increases. 

STA - Chainage. Distance in metres along the track from a given reference point. 

Pr - Chainage mark in metres. 

Km - Kilometre. Similar to chainage, but the unit is in kilometres. 

L - Straight element length. Used for horizontal elements. Unit in metres. 

http://www.trimble-railway.com/
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R - Radius for circular elements. Used for horizontal and vertical elements, in metres. 

A - Transition curve (clothoid/spiral) A-parameter. Used for transition curve elements. 
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 Installation and licensing 

 

This chapter describes the relevant information related to system requirements for software installation, 
license activation and configuration. 

In order to operate TRIMBLE GEDO NovaTrack, the computer requirements are as follows: 

 Microsoft Windows® 7 (32-bit OS), 8.1 and 10. 

 Processor: 1.2 GHz or higher 

 RAM: minimum 1 GB  

 

 Download TRIMBLE GEDO NovaTrack  
 

To download the latest version of TRIMBLE GEDO NovaTrack software, please follow the link and 
instructions: 

1. Go to the Trimble Track Survey & Scanning Support website at http://www.trimble-
railway.com/download . 

2. Enter your username and password and then click Login 

3. In the folder structure, select Subject and required Product (GEDO NovaTrack) 

4. Select the installation package to download. 

 

 Install TRIMBLE GEDO NovaTrack 
 

This paragraph provides information on how the TRIMBLE GEDO NovaTrack software can be installed on a 
Microsoft Windows® based PC computer.  

 Copy GedoNovaTrack_vX.X.exe installation package to a temporary PC folder. 

 Start GedoNovaTrack_vX.X.exe and follow the instructions on the screen. 

 After installation is completed, a GEDO NovaTrack shortcut will be created on the desktop. 

 In order to run software in US Feet units, please edit GEDO NovaTrack shortcut by changing 
´Target´ setting with command string: 

NovaTrackG.exe -USFEET 

 To run the program, double click the GEDO NovaTrack shortcut icon. 

 Create a folder for all GEDO NovaTrack project related data (f.e. C:\Gedo NovaTrack\Data ). 

 

 Software licensing 

 

In order to use all of TRIMBLE GEDO NovaTrack’s functionalities, a software dongle license is required. With 
a dongle license, the program can be installed on several PC’s but it can be started and used only on the PC 
where the USB dongle (or SD card) is plugged in. A dongle license requires the additional installation of the 
Wibu Codemeter software. 
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 Typical workflow 

 Alignment calculation using automatic smoothing 

 

Trimble GEDO NovaTrack provides a functionality for automatic processing of measured track data into 
horizontal alignment elements, using ´ NovaTrack 3.0´ method. 

The automatic processing workflow: 

Step 1. Import track measurement data by clicking Open -> (.GTD format file). 

Step 2. From the list select appropriate calculation profile (e.g. ´Adjustment new track´). 

Step 3. If required, adjust Main Calculation Constants (depending on track and measurement quality): 
´Min.straight line length´, ´Minimum uplift´ and ´Number of iterations´(1.  

Step 4. Press ´OK-Analyze´ to compute alignment. 

Step 5. Review calculated offsets. If required, adjust scale for horizontal and vertical offset in Tools -> 
Options.  

Step 6. Adjust individual horizontal alignment elements where offsets are beyond set tolerances. 

Step 7. Adjust gradient lines and PVI from the Vertical layout, so vertical alignment elements are 
within the limits of minimum uplift and upper tolerance. 

Step 8. If required, adjust calculated cant/speed values. Double click Cant Diagram. In the Speed/Cant 
table change ´h1´, ´h2´ and ´v´ fields. Select checkbox ´K´ to lock edited values. 

Step 9. Export alignment to GEDO Office file format by selecting File -> Save As.. -> All GEDO Office 
files format. The alignment data will be stored into three separate file formats: .TDT, .HDT and 
.UDT. 

 
(1 – In the NovaTrack 3.0 method it is recommended to adjust number of iteration between 1 and 20. Larger 
amount than 20 iterations will not have effect on final alignment result. 
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 Alignment calculation using semi-automatic method 

 

In the semi-automatic processing workflow, initial alignment measurement processing is done using 
´Regression with Transition Curves´ method. Further, using the Analysis Diagram tools, horizontal alignment 
elements are enhanced by extrapolating them based on track measurements. Semi-automatic workflow 
applies for tracks with poor geometry: 

 

The processing workflow using Analysis tools: 

Step 1. Import track measurement data by selecting Open -> .GTD format file 

Step 2. From the list select appropriate calculation profile (e.g. ´TR_Heavy_Re-alignment´). 

Step 3. If required, adjust Main Calculation Constants (depending on track quality): ´Error tolerance´´(1, 
´Min.straight line length´, ´Min.radius for transition curves´, ´Number of iterations´´(2.  

Step 4. Press ´OK-Analyze´ button to compute alignment. 

Step 5. Review calculated offsets. If required, adjust scale for horizontal and vertical offset in Tools -> 
Options.  

Step 6. Continue with further alignment adjustment in the Analysis Diagram. Depending on a track 
configuration, select Curvature 7 or Direction diagram . 

Step 7. In Analysis diagram activate continues calculation mode by selecting ´Calculate automatically. 
Alignment/offsets will be updated continuously while editing split points. 

Step 8. Adjust split point position by adding or removing redundant split points (e.g to minimize 
offsets).  

Step 9. Switch to Horizontal layout. If the horizontal offset values are still exceeding set limits, adjust 
individual horizontal alignment elements using element editing tools. Double-click element 
and adjust geometry parameters by observing offset trend. 

Step 10. Adjust gradient lines and PVI from the Vertical layout, so vertical alignment elements are 
within the limits of minimum uplift and upper tolerance. 

Step 11. If required, adjust calculated cant/speed values. Double click Cant Diagram. In the Speed/Cant 
table change ´h1´, ´h2´ and ´v´ fields. Select checkbox ´K´ to lock edited values. 

Step 12. Export alignment to GEDO Office file format by selecting File -> Save As.. -> All GEDO Office 
files format. The alignment data will be stored into three separate file formats: .TDT, .HDT and 
.UDT. 

 
(1 – In the ´Regression with Transition Curves´ method it is recommended to adjust ´Error tolerance´ based 
on track geometry quality. The higher tolerance generates less precise alignment solution. It is 
recommended to use tolerance range between 0.5 and 30 meters. 
(2 – Setting ´Number of iterations´ is directly related to ´Error tolerance´ setting and defines with what step 
increment ´Error tolerance´ will be increase. Calculation always starts with error tolerance 0.0 m and runs 
till it reaches maximum set value. At the end of the iteration process, software selects alignment solution 
which has smallest ´Sum of offset´ value. 

The higher iteration number can have effect on more precise alignment fitting.  
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 Menu structure and user interface 

 GEDO NovaTrack menu structure 

 

GEDO NovaTrack software menu structure 

File 
• Open... 
• Close 
• Save 
• Save As... 
• Print preview 
• Print setup 
• Project information 
• Import 

Edit 
• Undo 
• Delete 
• Delete element 
• Delete element and transition curve 

• Insert elements 
• Insert Curve  
• Insert Straight Line 
• Insert Transition Curve 
• Insert Curve in Straight line element 
• Insert Straight Line in Curve element 
• Split Curve 

• Select reference points 
• Change direction 
• AutoSnap 

View 
• Toolbars 
• Status bar 
• Normal (edit mode) 
• Zoom 
• Pan 
• Zoom previouse 
• Zoom out 2x 
• Zoom extents 
• Settings 

Tools 
• Cant & speed calculations 
• Options... 

Windows 
• Cascade 
• Tile 
• Layout 
• Diagrams 
• Horizontal map 
• Vertical map 
• Analyse map 

GEDO NovaTrack 
Main Menu 

http://www.trimble-railway.com/
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 Toolbar items 

 

GEDO NovaTrack has six different toolbars that gives access to the most frequently used 
command/functions. Holding the cursor on a toolbar button, a short description of the command is 
displayed. From the View menu, it is possible to choose which toolbars should be displayed, see Toolbars / 
Status line.  

The toolbar buttons have colour codes; blue is Horizontal window, green is Vertical window, grey is the 
Diagram window and red square symbol is the Analysis window. The predefined layout makes it easy to 
move the window to desired position. 

The toolbars can be moved as required. 

 

5.2.1 Standard toolbar 

 

  

Icon Function description 

 

Open existing project in .SPW or import new measurement data from GEDO .GDT file format 

 

Save project to .SPW or export data to GEDO Office alignment file format (.TDT, .HDT, .UDT) 

 Alignment re-calculation based user selected settings and setting profile 

 

The Undo tool reverts back changes made in the process of calculation or editing. Undo 
function is affecting data changes made both in horizontal/vertical views, analysis diagrams 
and alignment changes due to recalculation process. 

 
The Redo tool reverts forward changes made in the process of calculation or editing. Redo 
function is affecting data changes made both in horizontal/vertical views, analysis diagrams 
and alignment changes due to recalculation process. 

 

Show Result File. Provides detail summary of alignment data input and calculation results. 

 

Print. Using this tool, it is possible to print out the data in the Horizontal, Vertical and 
Schematic windows. The data for the active window view will be printed. The information 
defined in the function 'Project Information' will be used for the printout headers. 

 

Help. Opens the GEDO NovaTrack help file. 
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5.2.2 View toolbar 

 

 

Icon Function description 

 

Normal (Edit Mode). Switching from zoom or pan mode to Edit mode. The Normal (Edit mode) 
is the standard mode and gives access to editing and pointing functions. 

 

Pan. Moves the zoomed area by pressing the left mouse button and dragging the zoomed 
area into place. 

 

Zoom Window. Zooms in an area between the chainages. The area is defined by clicking at 
the ‘from chainage’ and at the ‘to chainage’. 

 

Zoom Previous. Zooms to the previous view. 

 

5.2.3 Mode toolbar 

 

 

Icon Function description 

 Mode Line (Not yet implemented) 

 Mode Point (Not yet implemented) 

 

Left to Right Drawing. Rotates the drawing and the coordinate system so that the horizontal 
alignment is shown from left to right. By default this option is activated. When the option is 
not checked, the drawing is shown with the x-axis direction upwards. Left to right drawing can 
also be switched on or off from the toolbar. 

 

AutoSnap.  Function is affecting element editing in horizontal, vertical and analysis diagram 
views. During element editing, when dragging existing tangent points or creating new, the 
function will automatically lock tangent point to a measured point. 

 

Change Horizontal Direction. When importing measurement data, the program will 
automatically start the chainage at the lowest X-coordinate, with increasing chainage 
northwards. This direction can be reversed using this tool. 
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5.2.4 Edit toolbar 

 

Icon Function description 

 Delete measure point (Not yet Implemented) 

 

Delete Intersection Point. The function deletes the active vertical curve, and its initial and 
final straight lines (grades) are joined into one element. 

 

 

Insert Intersection Point. Inserts curve in vertical alignment. The program prompts for the 
position of curve and element radius. 

 

Delete Element Only. First active element is marked with a thicker line within the horizontal 
window. Then active element is deleted. 

- Before activating this tool, make sure that the correct element is selected by clicking on 
it in the window 'Horizontal Map'. 

 

Delete Element and Transition Curves. Deletes active element along with the transition 
curves. 

- If the calculation fails ('Calc Not Ok' on status bar), the horizontal alignment has to be 
edited by the user until the calculation is successful. 

- Before activating this tool, make sure that the correct element is selected by clicking on 
it in the 'Horizontal Map' window. 

 

Insert Transition Curve. Inserts a transition curve (TC) after the active element. 

- If the calculation fails ('Calc Not Ok' at status bar), the horizontal alignment has to be 
edited by the user until the calculation is successful. 

- Choose 'Undo' to revert back to the last line calculation. 

 

Insert Curve. Inserts a curve (C) after the active element. 

- If the calculation fails ('Calc Not Ok' at status bar), the horizontal alignment has to be 
edited by the user until the calculation is successful. 

- Choose 'Undo' to bringing back the last line calculation. 

 

Insert Straight Line. Inserts a straight line (SL) after the active element. 

- If the calculation fails ('Calc Not Ok' at status bar), the horizontal alignment has to be 
edited by the user until the calculation is successful. 

- Choose 'Undo' to bringing back the last line calculation. 

 

Insert Curve in Straight Line Element.  Inserts a curve (C) along with transition curves (TC) at 
either ends of the active straight line element. 

- If the calculation fails ('Calc Not Ok' at status bar), the horizontal alignment is to be 
edited by the user until the calculation is successful. 

- Choose 'Undo' to bringing back the last line calculation. 

 

Insert Straight Line in Curve Element. Inserts a straight line (SL) along with Transition curves 
(TC) at either ends in the active curve element. 
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- If the calculation fails ('Calc Not Ok' at status bar), the horizontal alignment is to be 
edited by the user until the calculation is successful. 

- Choose 'Undo' to bringing back the last line calculation. 

 

Split Curve. Splits the active curve element. The old curve is split and two new curves are 
calculated from the measured data. 

 

Select Reference Point. The current start chainage reference point is replaced with a new 
reference point from the measurement data.  

 

5.2.5 Layout toolbar 

 

Icon Function description 

 Horizontal Map Diagram. Positions the Horizontal window above and the Schematic window 
below 

 Vertical Map Diagram. Positions the Vertical window above and the Schematic window 
below. 

 Vertical Map Horizontal Diagram. Positions the Vertical window to the left, Horizontal 
window to the bottom right and the Schematic window to the top right. 

 Horizontal Map Vertical Diagram. Positions the Horizontal window to the left, Vertical 
window to the bottom right and the Schematic window to the top right. 

 Hmap Vmap Diagram. Positions the Horizontal window above, the Vertical window in the 
middle and the Schematic window below. 

 Vmap Hmap Diagram. Positions the Vertical window above, the Horizontal window in the 
middle and the Schematic window below. 

 

5.2.6 Analysis toolbar 

 

 

Icon Function description 

 Analysis Diagram. Opens new Analysis diagram window. Use mouse right-click to select 
appropriate measured point visualization method: Curvature 3, Curvature 7 or Direction. 
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 Graphical User interface 
 

GEDO NovaTrack uses three movable and re-sizeable windows: Horizontal Map, Vertical Map, and Analysis 
diagram windows. These windows can be arranged within the user’s preferences. GEDO NovaTrack  also 
has pre-defined Layouts for these three windows. 

 

5.3.1 Horizontal map view 

 

The Horizontal window shows the Project’s horizontal alignment (current line calculation). The alignment 
can be shown in either a left-to-right direction, or orientated with the North direction pointing upwards on 
the screen depending upon the current view settings (see View  Settings).  

 

 

The horizontal alignment elements are colour coded:  

 green colour for straight line; 

 blue colour for transition curves or spirals; 

 red colour for circular curves; 

 chainage is marked with a blue ticks. 

 

Cross marks and circle marks are fixed points (tangent points), necessary for the alignment calculation. The 
fixed point position can be modified in the graphical interface. However, fixed points cannot be deleted or 
created, since they are connected to the alignment elements. 

The fixed points are colour coded, marked with different symbols and have the following meaning: 

 green fixed points belong to elements which are locked with two fix points. The first point is a cross 
and the second is a circle;  

 red fix points are locking the elements at one fixed position only. 

For a description on calculation methods, see 7. Definition of calculation methods. For a description on 
editing the alignment calculation, see 9. Alignment data calculation and editing. 

Straight line 

Circular curve 

Transition curve 

Two fixed points 

Single fixed points 

Chainage marks 

Overview window North indication 

Start chainage point Alignment element information and 
alignment fitting quality 
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In the top left hand corner of the Horizontal window, an aerial overview window of the complete alignment 
is shown, with the active view window marked in a darker colour. 

In the top right hand corner, a north arrow is shown. (Only when viewed in left-to-right mode) 

For viewing basic alignment element information, point the element using mouse left-click. A double left-
click opens the element Editing dialog (see 9.3.1 Workflow for manual horizontal alignment and offsets 
adjustment). A right-click opens a quick menu with appropriate commands: 

 

When the cursor is moved along the alignment, the chainage marker is shown at the cursor’s position. The 
active element is displayed using a bolder colour. When the cursor is pointed at a fixed point, the fixed 
point is marked with a filled, yellow circle. 

 

All calculated alignment elements which are outside the limits set in the selected user profile, are marked 
with a warning sign (triangle symbol) . When the mouse pointer is moved over the warning sign, the 
symbol is highlighted   and the status prompts with element validation information. 

 

  

Cursor position 

Active element information Calculation status 

Active element 

Overview window 

Element validation information 

Active element 

Warning sign highlighted 
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5.3.2 Vertical map view 

 

In the Vertical Map layout window, the vertical alignment of the project is shown. The alignment is shown 
as a graph with the chainage on the X-axis and the height (elevation, Z-value) on the Y-axis. The alignment 
is colour coded: straight elements are green and circular curves are marked in red.  

 

Cross marks and circles are fixed points necessary for the line calculation. 

Green fixed points belong to straight elements, where the first fixed point is a cross, and the second is a 
circle. Blue crosses represent the vertical angular points for the circular curves. 

For a description on editing the vertical alignment, please refer to chapter 9.3.3. Workflow for manual 
vertical alignment and offsets adjustment. 

In the top left hand corner of the Vertical window, a view over the complete vertical alignment is shown, 
with the current view marked in a darker colour. 

The user chooses an active element by clicking on it. Double-clicking an element opens the edit element 
dialogue box. A right-click opens a quick menu with appropriate commands: 

 

 

All calculated alignment elements which are outside the limits set in the selected user profile, are marked 
with a warning sign  (triangle symbol).  

  

Straight line 

Circular curve 

Element grade ‰ 

Fixed points 

Intersection 
Point 

Chainage 
and Radius 

Active element information Calculation status 

Overview window 
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When the mouse pointer is moved over the warning sign , the symbol is highlighted and the status 
prompts with element validation information. 

 
 

5.3.3 Diagram view 

 

The Diagram window displays information about the calculated/set speed, measured/calculated cant, 
vertical offsets, horizontal offsets and horizontal/vertical alignment curvature.  

 

 The Speed diagram (in km/h) shows calculated speed at each horizontal alignment element. The 
speed indication lines has different marking, which is dependent on element type (separated by 
colours) and calculated speed values (separated by line type).  

 Calculated Vmax speed for individual element (colour coded) 

 Calculated Vmax speed for individual element, considering 
neighbouring element speed (colour coded) 

 User set Vmax speed for individual elements (colour coded) 

 

  

Element validation information 

Active element 

Warning sign highlighted 
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The speed calculation regulations can be set or edited in the Calculation profile.  

Calculation profiles can be accessed from the toolbar, by selecting function Re-analyse or from the main 
menu Tools -> Options -> Calc.set. Use the same dialog to dedine new or edit existing profile. 

Vmax values are calculated based on calculation profile table and can be overridden with user define speed 
settings, in the Tools -> Cant and Speed calculations – Speed. 

 The Cant diagram (in millimeters) shows measured and calculated Cant values. Additionally, 
depending on alignment element type, calculated Cant values are coloured accordingly. The 
maximum scale for calculated Cant is set in the Calculation Profile settings (variable hmax). The 
calculated Cant values for the whole alignment can be access for editing by double-clicking on Cant 
graph.  

For editing of Calculation profile, please refer to chapter 6.4 Calculation profiles and Appendix 2. 
Calculation profile definition. 

 Measured Cant (black colour) 

 Calculated Cant for individual element (black colour) 

 Calculated Cant for individual element, considering neighbouring 
element speed and Cant according Calculation profile (colour coded 
depending on element type) 

 Overridden Cant by user (bolded, colour coded depending on element 
type) 

 

 The Vertical offset diagram (in centimetres) shows the offset between measured points and the 
vertical alignment calculation. Where the calculated line is above the measured point, the vertical 
offset is shown as above the 0-level (positive offset). The scaling of the vertical offset diagram can 
be set in Tools -> Options -> Project. 

 The Horizontal offset diagram (in centimetres) shows the offset between measured points and the 
horizontal line calculation. Where the calculated alignment is always following the 0-level, and 
measured points as the continuous black line are displayed on both side of 0-level axis. Offsets on 
the left side 0-level axis are ´positive´, and on the right side - ´negative`. The scale of the horizontal 
offset diagram can be adjusted in Tools -> Options-> Project settings. 

 The Curvature diagram (1/R) shows the curvature of the horizontal alignment. If measured point 
view “Show 3 (and/or 7-) point radius” (in View -> Settings dialog) is activated, these calculated 
points are visible in the Curvature diagram. The diagram also shows the vertical alignment, with its 
Intersection Points and vertical radii indicated with grey fields and arrowheads. 

 At the bottom of the Diagram window, the chainage information is displayed. 
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5.3.4 Analysis diagram view 

 

The Analysis window is used for semi-automatic analysis of the measured track data.  Based on the 
measured points, the program calculates horizontal track curvature as 1 / Radius and Direction changes.  
Calculated values are displayed along the chainage axis in the form of diagram. 

 

 

To switch between available Analysis diagram visualization modes, in the Analysis diagram view use mouse 
right-click and select appropriate data visualization mode from short-cut menu: 

Important! 

Analysis function only calculates horizontal alignment geometry. If the Manual or Automatic calculation 
function is activated, the available alignment geometry in the Horizontal view window will be replaced with 
the calculated alignment from Analysis diagram.  

  

  

Analysis diagram  

mode 

Comment 

Curvature 7 Invers radius curvature diagram, 7 point radius 

Curvature 3 Invers radius curvature diagram, 3 point radius 

Curvature 753 Invers radius curvature diagram, average of 7, 5 and 
3 point radius 

Direction Directional diagram based on direction change along 
the measured point 
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The Analysis calculation engine is relying on the user defined "split" points (in the Analysis diagram) which 
are representing  a preliminary locations for element tangent point. 

Each "split" point is connected with an horizontal alignment element and these elements are presented in 
the diagram view as preliminary guidelines for horizontal alignment calculation. The colour of the 
alignment elements has the following meaning: 

Color Element type 

Green Straight line 

Red Circular curve 

Blue Clothoid/Spiral (transition curve) 

Grey No element inserted between split points 

 

After the positions for the elements are identified and alignment is calculated in the diagram view, the 
result is automatically is synchronized with Horizontal view. Diagram recalculation and synchronization with 
horizontal view can be set in Manual or Automatic mode. To switch between the modes in the Analysis 
diagram view right-click and select/deselect calculation mode to Calculate automatically:  

 

 

 

Important! 

No element will be inserted between two ´split´ points that have fewer than 3 measured points between 
them.  

If the diagram elements between the split points are coloured in ´magenta´, it means that an alignment has 
an errors and therefore it can´t be calculated.  
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5.3.5 Status bar 

 

The Status bar shows information about the position of the cursor, active element and calculation status. 
The type of visible information varies depending on what windows are open and the type of active element. 
When the user is editing an element, a brief description of what the user should do is displayed. 

 

 

 To the left, the coordinates of the cursor are shown. When the cursor is in the Horizontal window, 
the coordinates are East-North. When in the Vertical window, the coordinates are Chainage-
Elevation. 

 The following symbol is a Padlock. The lock is green when there is no element selected for editing. 
When an element is activated for editing, by clicking on it, the padlock changes to red.  

 To the right of the Padlock, information about the current element is displayed - Element number, 
Element type, Coordinates, Chainage, Length and Radius (Transitions are displayed with Start and 
End radius). Displayed information about elements in the vertical alignment are Element number, 
Element type, Chainage for start and end, and Element length. 

 Further to the right, the status of the line calculation is displayed. When the calculation is 
successful, the text ‘'Calc Ok’ is shown in green. When the calculation is not successful, the text 
‘'Calc not Ok’ is shown in red. Double-clicking this field opens the result text-file.  

 Furthest to the right of the Status bar shows the current status for Caps Lock, Num Lock and Scroll 
Lock.  

 

When the specific element warning sign  is selected in the Horizontal or Vertical view, a status bar 
prompts with element validation information. 
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 Settings and options 

 

Settings and parameters in the GEDO NovaTrack software are grouped into the following groups: 

 Project settings  

 General settings 

 Grid and Map settings 

 Calculation profiles 

 

Important! 

These settings are stored on a software configuration level and within the project .SPW files. Settings 
covering calculation profiles are stored in ´Profiles.ini´ file (located in GEDO NovaTrack installation folder). 

 Project settings 

 

To access the Project setting group:  

 from the main menu select Tools -> Options 

 select the Project tab.  

 confirm changes by pressing OK button. 

 

 

 

Settings Comment 

Scale horizontal offset Scale for the Horizontal offset diagram values. Unit is metres 

Scale vertical offset Scale for the Vertical offset diagram values. Unit is metres 

Save as user default Saves as default settings.  
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Settings Comment 

Get user default values Restores saved user default values for this dialog box 

 General settings 

 

To access the General setting group:  

 from the main menu select Tools -> Options 

 select the General tab.  

 confirm changes by pressing OK button.  

 

 

 

Settings Comment 

Layout  

Choose default layout Sets the default layout window from the Predefined Window Layouts. 

Left to right drawing  Sets the default orientation for the horizontal alignment from the left-to-right 

North-south drawing Sets the default orientation for the horizontal alignment from according to 
the coordinate grid 

Files  

Remember last opened 
file type 

Not implemented in this version. 

Default load file type Sets the default file type for opening a project. 

Default Save as file type Sets the default file type for saving a project. 

Number of files in MRU 
list 

Sets the number of recently used files shown in the File menu. 
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Settings Comment 

Miscellaneous  

Edit feature codes Is used for changing or predefining feature codes for track centres or rails in 
in-data files.  

Change fonts Not implemented in this version. 

Edit profile… Create and edit calculation profiles 

  

 Grid and map settings 

 

To access the Grid and Map setting group:  

 from the main menu select Tools -> Options 

 select the Grid & Map tab.  

 

 

 

Settings Comment 

Grid  

Horizontal Size/Vertical 
Size 

Sets the size of the grid. Unit is metres. 

Horizontal 
Colour/Vertical Colour 

Sets the colour of the grid. Choose from the colour box. 

Line Width Sets the grid line width. Change to arrow-up or arrow-down. 

Line Type Sets the grid line-type. Choose available line-types from the drop-down list. 

Map  
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Settings Comment 

Feature code Lists feature codes in the imported map. The feature codes can be edited, but 
it is not possible to join feature codes into one. 

On Sets the feature code display status on/off. 

Color Sets the feature entity display colour. 

Type Sets the feature entity display line-type. 

Width Sets the feature entity display line-type width. 

  

 Calculation profiles 

 

There are two possibilities to access the Calculation profile settings:  

a) from the main toolbar, select Re-analise  

 

b) from the main menu, select Tools -> Options -> General 

 

 press ´Edit profile…´ button to view or edit calculation profiles. 

 to delete selected profile, press ´ Delete current profile ´ button. 

 To create new profile, press ´ New (copy from existing) ´ button. The new profile will be always 
created based on a selected profile values. 

 

Important ! 

Detail description of constants used in calculation profiles is listed in the Appendix 2. Calculation profile 
definition. 
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For the alignment re-calculation process, some of the most important constants are directly accessible from 
Re-analyze dialog: 

Settings Comment 

Selected Analyze 
method 

Regression method: 

- Novatrack 3.0: 

for track with good geometry quality 

- Regression with transition curves: 

for track with low-avarage geometry quality 

- Regression without transition curves: 

for track with low geometry quality. Transition curves will not be used in 
alignment approximation. 

Error tolerance Setting affecting precision for alignment element approximation. The less value, 
more ´constrained´ element fitting to the measured points. The error tolerance is 
iterated from zero to set error tolerance value. 

Min. straight line 
length 

Minimum length for the straight elements. The software will iterate the length 
from the set minimum length. 

Min. radius for 
transition curve 

Minimum radius for the transition curves. The software will iterate with 
transition elements (length, radius) starting from set radius value. 

Min. lift Applied minimum average vertical lift for vertical alignment elements 

Number of iterations Number of iterations for fitting horizontal alignment elements 
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 Definition of calculation methods 

 

GEDO NovaTrack software contains two main methods for automatic alignment fitting with measured 
points. Each method has its own features and individual requirements for the measurement data. 

 Alignment smoothing using the NovaTrack 3.0 method 

 
Horizontal alignment 

The method is based on the analysis of the track measurement data in a curvature diagram, instead of 
trying to compute the elements (straights, curves and transition curves) directly from the coordinates of 
the measured data. In the diagram, the software assembles the points into groups of seven and transforms 
the coordinates, from X-Y to Chainage – Curvature. In a curvature diagram, all the elements that are 
straight lines or curves are represented as straight lines (constant curvature has parallel offset to the R 
axis), and the transition curves have linear increasing or decreasing functions. The elements are dissolved 
from a regression analysis to find best-fit lines. When the elements are identified, they are transformed 
back to X-Y coordinates and the result can be calculated. 

 

Vertical alignment 

The gradient lines are found by assuming a "corridor" either side of the straight line and then the software 
will compute how far the straight line can be extended without crossing the corridor with set vertical offset 
tolerance ´error_tolerance_vertical´. The vertical intersection points are inserted at the intersection 
between straight lines. The radii are then calculated as having a tangent length of 20.0m. 

 

Demands on track measurement data 

The method is sensitive to the quality of the track measured data, but compared to the other methods, 
uses a more powerful algorithm for line calculation. With high quality on both track and measured data, the 
analysis will be capable of handling relatively complicated geometry. 

 

Important ! 

Detail description of ´Novatrack 3.0´ method specific calculation constants is listed in the Appendix 2. 
Calculation profile definition. 
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 Alignment smoothing using ´Regression with transition curves´ method 

 
Horizontal geometry 

This Analysis method is using the least squares method to find the straight lines in the alignment from the 
track measured coordinates and within user defined tolerances. Method is using measured data to 
calculate the “best” radius between straight elements. If a radius cannot be calculated, or calculated value 
exceeding 25000.0 meters, the radius is set to 10.0 m or 25000.0 meters. 

 

Vertical geometry 

Regarding vertical geometry, the least squares method is also used for establishing straight lines from the 
measured points, within the user given tolerance. From the measured data, software calculates the “best” 
radius between straight elements. If a radius cannot be calculated, or calculated to more than 50000.0m, 
the radius is set to 50000.0m. 

 

Demands on track measurement data 

The ´Regression with transition curves´  analysis is less sensitive in detecting S-curves and combined curves, 
especially when the minimum straight line length is set too long. In those cases, connecting straight lines in 
between the S-curve are not detected. 

The calculation of the transition curve parameter is also a relatively simple procedure and is done after the 
calculation of radii smaller than the radius given by the user. The analysis starts with the parameter A set to 
A = R/3, the length is reduced where there is no room for transition curves. 

The ´Regression with transition curves´ analysis has lower demands on the quality of the measured data, 
compared to the Novatrack 3.0, and will in most cases be able to find the straight lines. It is then up to the 
user to edit the geometry until a satisfying result is reached. The analysis will on the other hand have 
trouble with more complicated geometry, such as S-curves and combining spirals. 

In most cases the ´Regression with transition curves´ analysis will generate alignment geometry which can 
later be used for further optimization and adjustment. 

 

Note. 

Detail description of ´Regression with transition curves´ method specific calculation constants is listed in 
the Appendix 2. Calculation profile definition. 
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 Alignment smoothing using Analysis Diagram tools 

 

7.3.1 Analysis Diagram introduction 

 

The Analysis diagram tool is used to manually or semi-automatically adjust horizontal alignment elements 
and overall horizontal alignment quality based on the track measured points. 

Once measured points are automatically processed within set number of iterations, using `Novatrack 3.0` 
or ´Regression with transition curves´ methods, elements can manually or semi-automatically be further 
adjusted in these two primary Analysis diagrams: 

 Curvature 7 (measured data is shown as 1/Radius, using 7 points) 

 Direction (measured data is shown as direction change) 

 

To switch between the available Analysis modes, in the Analysis diagram use mouse right-click to switch 
between Analysis mode: 

 

 

 

 

  

Analysis mode Comment 

Curvature 7 Curvature diagram, based on 7 point radius 

- Diagram recommended to analyse track curvature 
with moderate-good geometry quality. 

Curvature 3 Curvature diagram, based on 3 point radius 

- Diagram recommended to analyse track curvature 
with good geometry quality. 

Curvature 753 Curvature diagram, based on average of 7, 5 and 3 point 
radius 

- Diagram recommended to analyse track curvature 
with good-very good geometry quality. 

Direction Direction diagram, based on measured points direction 
vector changes in a chainage direction: 

- Diagram recommended to analyze track curvature 
with low-very good geometry. The Diagram is very 
efficient to analyze track geometry on a long straight 
and radii stretches. Direction diagram is also highly 
supportive when curvature pattern can´t be 
recognized by Curvature 7, 3 or 753 analysis mode. 
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Analysis diagram -  Curvature 7 

 
 
 

 
Analysis diagram - Direction 

 

Important! 

Analysis diagram function calculates only horizontal alignment geometry. If the alignment is recalculated in 
Automatic mode, alignment geometry in the Analysis diagram will be overridden with new alignment 
result.  

 

  

Measured points 
(dark grey) 

Straight line 
element (green) 

Transition curve 
element (blue) 

Circular curve 
element (red) 

Split points 
(green) 

Chainage axis 

Direction 
change axis 

Measured points 
(dark grey) 

Straight line 
element (green) 

Transition curve 
element (blue) 

Circular curve 
element (red) 

Chainage axis 

Split points 
(green) 

Radius axis 

Radius = 0 

Measured Cant 
(light grey) 

Cant axis 

Measured Cant 
(light grey) 

Cant axis 
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7.3.2 Analysis diagram editing and calculation 

 

In the Analysis diagram view, calculation of horizontal alignment can be done in following ways: 

 right-click and select Calculate Automatically (continues real-time calculation) 

 right-click and select Calculate Horizontal (single calculation) 

 pressing C key (single manual calculation) 

 pressing V key (single manual calculation, just visible part of alignment) 

 

In the Curvature 7 , Curvature 3 and Curvature 753 diagram the following rules apply: 

 straight elements always follow the measured points along the chainage, with R = 0 

 circular curve elements are parallel to chainage axis, with constant R offset 

 transition curves are linearly ascending or descending relatively to R and Chainage axis. 

 split points are inserted at diagram locations, where the point sequence is starting to change the 
Radius. 

 

 

Split point positioning within Curvature 7 and Curvature 3 analysis diagram 

 

Measured 
points 

Straight line 
element 

Transition 
curve element 

Circular curve 
element 

Split points 

Measured 
Cant 

Radius axis 

Chainage axis 

Cant axis 
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Important! 

Split points just indicates the preliminary position for element tangent points, however the precise position 
will be determined after element precise approximation process is completed. 

 

In a Direction diagram the following rules apply: 

 straight elements are always parallel to the Chainage axis, with Direction change = 0. 

 circular curve elements are ascending or descending along measured points, relative to the 
Direction and Chainage axis. 

 transition curves are established at diagram segments, where the direction of measured points 
starts to transition from `0 deg. to constant angle´ or from ´constant angle to 0 deg.´. 

 split points are inserted at the diagram locations, where the measured point sequence starts to 
change the Direction angle. 

 

 

Split point positioning within Direction analysis diagram 
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Each "split" point is connected to an horizontal alignment element, and these elements are presented in 
the diagram as a ´guidelines´ for horizontal alignment calculation. The colour of the alignment elements has 
the following meaning: 

Color Element type 

Green Straight line 

Red Circular curve 

Blue Clothoid/spiral (transition curve) 

Grey Connection between elements without transition 

When the elements are identified and an alignment solution is calculated, the alignment elements from the 
Analysis diagram are transformed back to X-Y coordinates. 

 

Important! 

No element will be inserted between two "split" points that have fewer than 3 measured points in between 
them.  

If the grey colour line is drawn between split points, it means that an alignment elements will be connected 
without transition curve (SL – C or C-C).  

Split points just indicates the preliminary position for element tangent points, however the precise position 
will be determined after element precise approximation process is completed. 
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7.3.3 Analysis diagram short cut tools 
 

In order to accelerate work process with element adjustment process in the Analysis Map, the software 
provides a set of commands and tools. 

 

7.3.3.1 Commands and tools valid for Curvature and Direction analysis diagrams 

 

Short key Command 

Editing  

Left-click & drag Pan diagram view along the chainage 

Left-click ´split´ point Snap to ´split´ and change position 

Shift+ mouse cursor over 
´measured point´ 

Snap to ´measured´ point. Status bar will indicate information about the 
selected point 

Mouse cursor over ´split´ 
point + Delete 

Deletes selects ´split´ point 

Important! 

- Always move mouse cursor over a split point (turns RED) and then 
activate function. 

Shift + Left click over ´split´ 
point 

Moves the split point to Radius = 0 and/or direction D = 0 

Important! 

Shift+ Delete Delete selected measured point. 

Important! 

- Firstly, always move mouse pointed over measured point (turns into 
Circle). 

- While keeping the Shift key down and continue pressing Delete key, 
the function will continue to delete measured points, starting from 
the nearest to the previously deleted. 

Ctrl-Z or  Undo and redo changes 

Double click or INS key Inserts new split point by snapping to nearest measured point 

A Calculates element average radius to the next split point. 

Important! 

- Always move mouse cursor over first split point of the element (turns 
RED) and then press A key. 

- In the Curvature 7 and 3 diagrams the averaging function applies to 
straight and circular curve elements. 

- In the Direction diagram averaging function applies to straight 
elements only. 

C Calculates complete horizontal alignment  

V Calculates just visible horizontal alignment elements 

Important! 
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Short key Command 

- Prior to activating this function, make sure that the alignment is in 
the window area and not starting or ending with a Clothoid element 
(transition curve). 

D Changes alignment direction 

E Erases all split points 

S Turns snap to the measured points On/Off 

X Turns split points in the diagram On/Off 

3 Turn 1/Radius Curvature 3 On/Off 

O Filter out measurement bias in Curvature 3, 7 and 753 diagrams 

Important! 

- Filtering function can be applied in the Curvature 3, 7 and 753 
diagrams only. 

 

Note. 

The function behind the key Delete require that the mouse pointer is placed over a "split" point and that 
the split point colour is changed to red. A red colour indicates that the point is selected and active. 
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7.3.3.2 Commands and tools valid for Direction Analysis diagrams only 

 

Semi-automatic measurement data Analysis in the Direction diagram can be done in the following ways. 
These three analysis methods help to identify split point locations. 

Short key Command 

Split point accelerator (Commands are only valid in the Direction Analysis Map) 

L Insert split points using direction change. Measured point analysis is based 
on a graphical directional change. 

P Insert split points using radius alteration. Measured point analysis is based 
on the change of radius along the graph. 

O Insert split points using direction line regression. Measured point analysis 
is based on the fact that elements in the graph are calculated according to 
line regression. 

Q Calculated of direction and measured point data displayed as Curvature 

 

Important ! 

At any given point, a manual adjustment of the analysis split point locations and their quantities may be 
required to achieve an alignment solution. 
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Analysis based on directional change along the graph (L key): 

 

  
nPnt – number of points in a single 

analysis array 

aPnt – number of points for 

calculating average direction 

dD – maximum direction change 

between two vectors 

The analysis assumes nPnt points at a time, calculates 

the average direction (y-value) at the first, middle and 

last aPnt point. These 3 values provide two directional 

vectors used to determine whether the graph changes 

direction. The parameter dD is the maximum 

directional change between the two vectors. The 

lower the dD value, the more exacting the analysis 

(will generate more split points). 

 

A split point is automatically inserted when 3 

subsequent calculations show the same directional 

change along the graph or if the directional change 

along the graph exceeds dD. 

 

 

Analysis based on change of radius along the graph (P key): 

 

  
nPnt – number of points in a single 

analysis array 

aPnt –  number of points for 

calculating average direction 

dR% – maximum radius change 

between two vectors 

The analysis assumes nPnt point at a time, calculates 

the average direction (y-value) at the first, middle and 

last aPnt point. These 3 values provide two directional 

vectors used to calculate the radius at the beginning 

and at the end of these nPnt. 

 

A split point is automatically placed when radians in 3 

subsequent calculations show the same directional 

change along the graph or when the next radius 

deviates more than ±dR% percent of the previous 

calculated radius. The lower the dR%, the stricter the 

analysis (will generate more split points). 
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Analysis based on line regression along the graph (O key): 

 

  
dMax – maximum difference 

between real direction and 

calculated direction 

rMin – minimum regression 

coefficient (must be between 

0 and 1) 

 

Split points are automatically inserted by finding straight lines using line 

regression analysis. 

 

The analysis starts by finding a line through the first 4 points. Based on 

the regression line cutting the y axis (direction axis) and the derivative 

line, one direction is calculated at each measured point. This value will 

probably differ from the real direction of the measured point, and this 

deviation is called delta. rMin is the least regression coefficient, and the 

greater rMin value, the tighter the  analysis (will generate more split 

points). 

 

As long as delta is less than dMax and the regression coefficient is less 

than rMin, the regression line is assumed to be acceptable and the next 

point will be included in the next regression. If not, the new line is 

assumed and a split point is placed at the end of the line. 

 

Important! 

The regression analysis is vulnerable to the measurement errors, and requires extremely good data. 
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 Data import and export 

 

GEDO NovaTrack software supports data interoperability with the following file formats: 

 

Format Read Write Description 

SPW (.spw) + + Native GEDO NovaTrack project file format 

KOF05 (.kof) + + Points, lines and alignment geometry (tabular, ASCII) 

Lifting scheme (.lft)  + Alignment geometry report (ASCII) 

PXY (.pxy) + (1  Points and lines (tabular, ASCII) 

GPS (.gps) +  Points (tabular, ASCII) 

Offset table (.alc)  + Alignment offset report (tabular, ASCII) 

Comma separated (.csv)  + Alignment geometry report (tabular, ASCII) 

NovaPoint (.tit) + + Horizontal alignment geometry (ASCII) 

Point file (.lin) + + Alignment geometry (tabular, ASCII) 

Intergraph (.dat) + + Horizontal alignment geometry (tabular, ASCII) 

NYPL (.nyl) + + Horizontal alignment geometry (tabular, ASCII) 

NADB (.ndb) + + Alignment geometry (ASCII) 

XRoad (.txt) + + Alignment geometry (tabular, ASCII) 

WinALC Geo (.geo)  + Alignment geometry Plasser/Thuerer (ASCII) 

WinALC Ver (.ver)  + Alignment offsets Plasser/Thuerer (ASCII) 

GEDO Office TDT (.tdt) + + Horizontal alignment geometry (tabular, ASCII) 

GEDO Office HDT (.hdt) + + Vertical alignment geometry (tabular, ASCII) 

GEDO Office UDT (.udt) + + Cant alignment geometry (tabular, ASCII) 

LandXML (.xml) + 2) + Points and horizontal/vertical alignment geometry 

(1 - can be imported as background map data only 
2) - import supports LandXML cgPoint elements only. 
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 Import of GEDO measurement data 

 

Track measurement data for alignment re-establishment is imported from the GEDO Office .GTD format 
files: 

 From the main menu select File -> Open  

 Select file type to GEDO Office *.GTD 

 As part of the import process, a dialogue box NovaTrack Analyze will open. The dialogue box 
enables you to select already predefined Calculation profile for data analysis and alignment 
optimization.  

 

During the measured data import, the software will perform data check and error correction, including:  

 data sorting 

 duplicate point removal 

 non-track related points removal 

 estimate of measured track length 

 

Status for the sorted data is shown in right hand side of the dialogue box. 

 Choose existing calculation profile or create new. Calculation profile is linked with analysis method, 
so ´Selected Analyses Method´ option do not have to be selected separately.  

 

Calculation profile contains both calculation constrains and alignment validation criteria’s. 
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 Adjust main calculation constants, so they correspond with measured track quality and expected 
alignment result. The higher iteration number will produce smaller step with error tolerance 

 

 

Setting Comment 

Error tolerance Setting affecting precision for alignment element approximation. The 
less value, more ´constrained´ element fitting to the measured points. 
The error tolerance is iterated from zero to set error tolerance value. 

Min. straight line 
length 

Minimum length for the straight elements. The software will iterate 
the length from the set minimum length. 

Min. radius for 
transition curve 

Minimum radius for the transition curves. The software will iterate 
with transition elements (length, radius) starting from set radius 
value. 

Min. lift Applied minimum average vertical lift for vertical alignment elements 

Number of iterations Number of iterations for fitting horizontal alignment elements 

 

 

 Press Ok – Analyze button to proceed with calculation.  

 The software will run iteration process by evaluating alignment options for the best available 
solution within set constrains: 

 

 

 

 At the end of the iteration process, software selects alignment solution which has smallest ´Sum of 
offset´ value. 
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Note. 

If the alignment solution with particular measurement data cannot be calculated, it is recommended to re-
adjust main constants. 

 

 

Please refer to chapter 7.Definition of calculation methods for detailed method description and demands 
for measurement data. 
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 Import of background map data 

 

For geographical orientation, track fix points and background maps can be imported as background map 
data sets from .KOF, .PXY or .GPS file formats: 

 From the main menu, select File –> Import Map… 

 From the drop down list select the suitable file format ‘Files of Type’ of the dialog. 

From the list select the file for the import and press Open. 

 The dialogue ‘Options’ with the tab ‘Grid & Map’ will be opened.  

 Check configuration of feature codes, colours and line-types. For a more detailed description of the 
settings please refer to section ‘Grid and Map settings’. 

 

 

Press OK to accept grid and map settings. 

 After the import, the background map data will be visible in the Horizontal Map layout, along with 
measured point information and design alignment elements. 

 
Background map data along with horizontal alignment 

Primary horizontal alignment 

Background map elements 

Background map elements 
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Important! 

Background map elements are visible in the Horizontal Map view only. 

The background map cannot be edited or stored in the GEDO NovaTrack project file (*.SPW). 

 

To choose whether the background map should be visible or not, use the settings in the menu File -> View -
> Show Map. 
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 Alignment data export 

 

GEDO NovaTrack software can export (‘Save As’) calculated alignment geometry and offset data to several 
file formats and reports. For more detail information on supported file formats please refer to             
chapter 8 Data import and export. 

 

To export complete alignment data for further use in GEDO Office software:  

 From the main menu select File -> Save As…  

 Select file format – All GEDO Office files (*.*). The alignment data will be exported into GEDO Office 
native alignment file formats: 

*.TDT - Horizontal Alignment data. 

*.HDT – Vertical Alignment data. 

*.UDT - Cant Alignment data. 

 

Additionally, it is recommended to store processed measurement data and calculated alignment geometry 
in GEDO NovaTrack software (this will include measured points, analysis diagrams, cant data, design 
elements and speed information):  

 From the main menu select File -> Save As…  

 Select file format – SPW file (*.SPW) 
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 Alignment data import and editing 

 

GEDO NovaTrack software can import (‘Import’) calculated alignment geometry (horizontal, vertical and 
cant) from several file formats. For more detail information on supported file formats please refer to             
chapter 8 Data import and export.   
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 Alignment data calculation and editing 

 Automatic calculation of horizontal and vertical alignments 

9.1.1 Automatic calculation of horizontal alignment 

 

To continue with the automatic calculation of horizontal alignment elements, proceed with following steps: 

 From the main menu select File -> Open (select measurement data in .GTD file format) 

 Select calculation profile based on ´Regression with transitions curves´ or ´NovaTrack 3.0´ method 

 

 

 In the calculation method dialogue press Configure to set calculation constants: 

´Regression with transition curves´  

  

 

Recommended setting  
´Regression with transition curves´ 

Value 

Error tolerance 0.5 < ITERATIONS < 30 

Min. straight line length  5 < L < 20 meters 

Min. radius for transition curve 2500 < R < 4500 

Number of iterations 50 < ITERATIONS < 200 
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Recommended setting  
´NOVATRACK 3.0´ 

Value 

Min. straight line length  5 < L < 20 meters 

Number of iterations 1 < ITERATIONS < 20 

 Press OK-Analyze button to start calculation. 

 After the calculation with set number of iterations is completed, software will prompt dialog with 
result summary: 

 

 Press OK button to confirm calculation result. 

At the same time the status bar will indicate in a green message ´CALC OK´.  

 

 Then also check the calculated offsets in the Diagrams –> Horizontal Offset. 

 

 

  

Calculation status 
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When software fails to find the alignment solution within set limitations, alignment status is indicated in 
red marking with the message ´CALC not OK´.  

 

 

To re-calculate alignment with different settings (i.e. with smaller error tolerance):  

 From the main toolbar select Re-analyse command. 

 The command will open initial NovaTrack Analyze dialog. Adjust the settings by editing selected 
calculation profile ´Edit profile´ or by changing calculation profile ´Main calculation constants´ . 

 Press ´OK-Analyse´ to recalculate the result. 

 

 

 The new results will be directly updated on the screen. 

 

Important ! 

Re-calculation process will use last edited version of measured data. Thus, all measured points which were 
deleted before recalculation, will not be considered in the consecutive calculations. 

Re-calculation process can be restored to previous versions using UNDO or REDO commands. 
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9.1.2 Automatic calculation of vertical alignment 

 

Automatic calculation of vertical alignment uses same selected Calculation profile as horizontal alignment. 
Calculation for vertical alignment is completed simultaneously with the calculation of horizontal alignment.  
Vertical alignment smoothing is directly dependant on set ´error_tolerance_vertical´ value in the 
Calculation profile. 

 To view and verify vertical alignment, switch the layout view to Window -> Vertical Map: 

 

 

 

 In the Diagram view, check that the vertical alignment offsets (lifts) from measured points are 
within the set tolerance limits: 
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 If the vertical alignment offsets from the measured points are below the ´min. lift tolerance´ or 
above the maximum lift limits, adjust Vertical alignment approximation settings (min_lift and 
error_tolerance_vertical) in the Calculation profile and re-run calculation.  

If the new result is still outside requirements, continue with alignment manual editing and 
adjustment using manual editing tools, as described in chapter 9.3 Manual alignment editing and 
fine-tuning. 

 

Note. 

Vertical alignment minimum vertical uplift can be adjusted in the Calculation profile (min_lift). The software 
will recalculate vertical gradients to fit new calculation settings. 

Decreasing of Calculation setting ´error_tolerance_vertical´ will increase amount of gradient elements and 
decrease offsets between measured points. 

To increase visibility of vertical offset value in the diagram vertical offset field, adjust  ´Scale vertical offset´ 
parameter in the dialog Tools -> Options -> Project. Save values as User Default, so they can be recalled at 
any time. 
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 Calculation of horizontal alignment using the Analysis diagram 

 

Measurement data from track with poor quality (geometry), can have a negative influence to automatic 
calculation results. This circumstance can prevent automatic process from finding right element 
configuration within set tolerance limits. As result, calculated alignment can have significant offsets, which 
are beyond set tolerance limits. To Overcome this issue, it is recommended with alignment editing in 
analysis diagram mode. 

To switch to element analysis diagram mode: 

Switch Layout view to Analysis Diagram, from menu selecting Window -> Analyse map. 

 Right-click on the diagram and select diagram type: Curvature 7 or  Direction. 

 To make sure that Analysis diagram has latest calculation result, in the Horizontal view press ´S´ key. 
The data between views will be synchronized.  

 

 

In the analysis diagram, each horizontal alignment element is limited by two split points. 

 

Direction diagram. Before editing split points 
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 Adjust alignment elements by adding or removing split points. Check the chapter 7.3.2 Analysis 
diagram editing and calculation for split point insertion rules. 

 

Direction diagram after editing 

 

 Once the diagram editing is completed, re-calculate the alignment with new definitions.  

To perform single alignment recalculation, press mouse right-click and from the short-cut menu select 
Calculate Horizontal.  

Alternatively, from the short-cut menu select ´Calculate automatically´ to activate ´real-time´ recalculation 
option. 

 

 

Note. 

To insert new split point, double click with a mouse and new split point will be added. 

To delete split point, move mouse cursor over the split point and press Delete key. 

To move the split point, press left mouse key on the split point and drag the cursor. 

To activate split point snap to measured point, in the main toolbar select button .                             

  

Split point positions after 
editing 
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As result, the elements from the analysis  diagram are transformed to the absolute alignment position. To 
view horizontal alignment offsets while editing diagram, arrange the windows in the way that both analysis 
and offset diagrams are in the same view.  

 

 

Note. 

Scale for horizontal offsets can be adjusted in the 6.1 Project settings.  

Manual alignment element fine-tuning procedure is described in the chapter 9.3 Manual alignment editing 
and fine-tuningError! Reference source not found.. 

 

 

Important ! 

Editing of alignment elements in the analysis diagram can cause alignment calculation to fail because, 
element configuration and position is no longer mathematically solvable. This is then indicated on the 
status bar - Calc not OK. 

To diagnose the calculation error or review calculation results in the numeric form, double-click the Calc 
OK/not OK indication. This will open the calculation protocol. The calculation report is updated with every 
new calculation. For more detail information about the calculation report, please refer to the chapter 10 
Calculation report data. 

 
 
 
 

 
  

Analysis diagram 

Offset diagrams 
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 Manual alignment editing and fine-tuning 

 

There alignment geometry editing tools are accessible from the Horizontal Map and Vertical Map views. 

Alignment and geometry elements can be edited and fine-tuned in three different ways:  

 by adjusting the position of fixed (tangent) points 

 by adjusting the parameters of geometry elements 

 by adding/splitting/deleting geometry elements  

 by changing alignment chainage information 

 

9.3.1 Workflow for manual horizontal alignment and offsets adjustment 

 

After the horizontal alignment calculation is completed using the automatic method or semi-automatic 
approach with the Analysis diagram, there still can be residual horizontal offsets, that are exceeding the 
maximum track tamping limit. Further precise adjustment of the offsets can be done directly by editing the 
parameters of the individual alignment elements: 

 for straight line: fixed point coordinates (start, end); 

 for transition curve: length and/or A-parameter; 

 for circular curve: radius, length, start point coordinate (if element is Partly fixed). 

 

Each element position is controlled by maximum two fixed points. Depending on the element order, the 
software requires none (Approximate), one (Partial) or two (Fixed) fixed points per element. The software 
automatically determines how many fixed/tangent points are needed for each element. For the horizontal 
alignment fixed points are given with X- and Y- coordinates. 

 

  

http://www.trimble-railway.com/


TRIMBLE GEDO NovaTrack User Manual  9 Alignment data calculation and editing  

 

Page 60 v. 2.0.1.  www.trimble-railway.com 

Manually to adjust horizontal offsets, proceed as follows: 

 Identify alignment elements where the horizontal offsets are exceeding the pre-set limits. 

 Zoom in to the Diagram window or Horizontal Map window, so the screen is covering principal 
element and two adjacent elements. 

 

 
 

 Right-click on to the Horizontal Map layout. From the command list activate Normal (edit mode). 
When Normal (edit mode) is activated, the mouse cursor follows the element geometry and allows 
them to be selected for detail editing. 

 

 

 

 Use the left mouse click to select the geometrical element for editing. Selected element 
information is displayed in the Status bar. 

 

  

Offset limits 
in cm 

Offsets from 
design in cm 

Offset 
adjustment 
area 

Design 
alignment 
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Note. 

If the offset values at the Circular curve element are largest, it is recommended to start  editing from the 
connected transition curve elements (TC1) and (TC2), and only after that switch to the circular curve (C3) 
editing. 

 

 
 

 Open the geometry editing dialogue box by making a double left-click on the activated element. 

 

Transition curve dialogue box 

 

Input data: length or A-parameter 

 

 

 

Activated 
element for 
editing 

TC (1) TC (2) C (3) 

Offset ´+´ 

Offset ´-´ 
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Circular curve dialogue box 

 

Input data: radius and a 

 

Fixed point status (auto selected): fixed, partly, approx., 
appr.radius 

 

Greyed out fields cannot be edited and are selected by the 
software to automatically compute a best solution 

 

 

 

Straight line dialogue box 

 

Input data: Start and end fixed point coordinates 

 

Fixed point status (auto selected): fixed, partly, approx. 

 

Greyed out fields cannot be edited and are selected by the 
software to automatically compute a best solution 

 

 

 Change an element´s parameters by using the up/down arrows for each field. During editing, the 
alignment and offsets are automatically updated. When values are entered directly, press 
´Calculate´ to update geometry and offsets. 

 

Note. 

if an offset is positive ´+´ (on the left side of alignment), the element radius/length has to be decreased; 

if an offset is negative ´-´ (on the right side of alignment), the element radius/length has to be increased; 

by changing element coordinates using up/down arrows       both ´X´ and ´Y´ coordinates are affected 
simultaneously, with a step of 7 cm; 

by changing individual ´X´ or ´Y´ element coordinate, will have affect to element direction. 
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 If further editing required, switch to the next element by selecting ´Next element´ or double left-
click on the element and the dialogue box information will be updated. 

 

Important! 

if the alignment solution cannot be calculated Calc not Ok, press the Undo key (Toolbar) to return the 
parameter value to its previous state; 

redundant or faulty element can be deleted directly using element editing dialog, by selecting element and 
pressing ´Delete element´ button; 

To diagnose the calculation error or review calculation results in the numeric form, double-click the Calc 
OK/not OK indication. This will open the calculation protocol. The calculation report is updated with every 
new calculation. For more detail information about the calculation report, please refer to the chapter 10 
Calculation report data. 

 

 

 

 

 

 

 
  

http://www.trimble-railway.com/


TRIMBLE GEDO NovaTrack User Manual  9 Alignment data calculation and editing  

 

Page 64 v. 2.0.1.  www.trimble-railway.com 

9.3.2 Functions for horizontal alignment editing 

9.3.2.1 Delete element only 

 

Icon/Key Function description 

 

To Delete Element Only: 

 

 Select alignment element using mouse left-key . Selected element will 
become a thicker line.  

 Press mouse right-key and choose Delete. 

 

 If the alignment calculation is 'Calc not Ok', it has to be edited manually 
until the line calculation turns to 'Calc Ok' or apply UNDO command to 
cancel changes. 

 

9.3.2.2 Delete Element with Transition Curves 

 

Icon Function description 

DEL 

To delete an element and the connected Transition Curves:  

 

 Select the alignment element using mouse left-key. Selected element will 
become a thicker line.  

 Press DEL key to delete the element. The activated element and 
connected transition curves will be deleted. 

 

If the alignment calculation is 'Calc not Ok', it has to be edited manually until the 
line calculation turns to 'Calc Ok' or apply UNDO command to cancel changes. 

 

9.3.2.3 Insert Curve (Circular) 

 

Icon Function description 

 

To insert a Curve after the active element: 
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 Use mouse left-key to mark the element after which you want to insert a 
circular curve element. Selected element will become a thicker line and 
marked with a red padlock symbol on the status bar. 

 Press Insert Curve icon to insert new element. 

 

If the alignment calculation is 'Calc not Ok', it has to be edited manually until the 
line calculation turns to 'Calc Ok' or apply UNDO command to cancel changes. 

9.3.2.4 Insert Straight Line 

 

Icon Function description 

 

To insert a straight line after the active element: 

 

 Use mouse left-key to mark the element after which you want to insert a 
straight element. The selected element will contain thicker line and 
marked with red padlock on the status bar. 

 Press Insert Straight line icon to insert new element. 

 

A straight element cannot be inserted after a straight element and cannot be 
connected to another straight element. 

 

If the alignment calculation is 'Calc not Ok', it has to be edited manually until the 
line calculation turns to 'Calc Ok' or apply UNDO command to cancel changes. 

 

9.3.2.5 Insert Transition Curve 

 

Icon Function description 

 

To insert a Transition Curve after the active element: 
 

 Use the mouse left-key to mark the element after which you wish to insert a 
transition curve element. Selected element will contain a thicker line and 
marked with red padlock on the status bar. 

 Press Insert Transition Curve icon to insert new element. 

 

If the alignment calculation is 'Calc not Ok', it has to be edited manually until the line 
calculation turns to 'Calc Ok' or apply UNDO command to cancel changes. 
 
Choose 'Undo' to revert back to the last line calculation. 
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9.3.2.6 Insert Curve in Straight Line Element 

 

Icon Function description 

 

To insert a Circular Curve element together with transition curves at either end into 
an active straight line element: 

 

 Use the mouse left-key to mark a straight line element, which will be split with 
the curve.  

 Run the function to insert a curve. 

 The program prompts for the location of a horizontal angular point of 
curvature (follow the messages in the status bar). 

 Pick the intersection /angular point. 

 By default, the program will insert a Circular Curve with a radius of 55.0 m and 
two transition curves at both ends with lengths of 15.0 m each. 

 When it is not possible to insert a Circular Curve inconjunction with transition 
curves, the transition curves will be discarded. 

 

When AutoSnap is active, the reference point will automatically snap to nearest 
measured point. Autosnap is switched on/off with the key F9. 

 
If the alignment calculation is 'Calc not Ok', it has to be edited manually until the line 
calculation turns to 'Calc Ok' or apply UNDO command to cancel changes. 
 
Choose 'Undo' to resort back the last line calculation. 

 

9.3.2.7 Insert a Straight Line in to Curve Element 

 

Icon Function description 

 

To insert a Straight Line with Transition Curves into a Circular Curve Element: 

 

 Use the mouse left-key to mark the Circular Curve element, into which 
will be inserted a straight line and transition curves at both ends.  

 Run the function to insert a straight line. 

 The program prompts for two tangent points (end points) for the straight 
line element (follow the messages in the status bar). 

 Pick the end points of the straight line. The selected point coordinates 
are displayed on the status bar. 

 By default, the program will insert Straight line element and two 
transition curves at both ends with the length of 15.0 m each. 
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 When it is not possible to insert a straight line with transition curves, the 
transition curves are discarded. 

 

When AutoSnap is active, the reference point will automatically snap to the 
nearest measured point. Autosnap is switched on/off with the key F9. 

 
If the alignment calculation is 'Calc not Ok', it has to be edited manually until the 
line calculation turns to 'Calc Ok' or apply UNDO command to cancel changes. 

Choose 'Undo' to revert back the last line calculation. 

 

9.3.2.8 Split Curve 

 

Icon Function description 

 

To split the active Circular Curve element into two new Circular curves: 
 

 Use the mouse left-key to mark the Circular Curve element, which will be 
split.  

 Run the function to split the active curve. 

 The program prompts for two points (observe the status bar). One point 
is desired split point for the curve and the second point - fix point on one 
of the new curves. 

 The old circular curve is split and two new circular curves are calculated 
from the measured data. 

 

When AutoSnap is active, the reference point will automatically snap to nearest 
measured point. Autosnap is switched on/off with the key F9. 

 
If the alignment calculation is 'Calc not Ok', it has to be edited manually until the 
line calculation turns to 'Calc Ok' or apply UNDO command to cancel changes. 
Choose 'Undo' to bringing back the last line calculation. 

9.3.2.9 Select Reference Point (change alignment chainage) 

 

Icon Function description 

 

To change chainage a reference point (start chainage): 
 

 From the toolbar run the function Select Reference Point 

 In the function dialogue box press the button ´Pick a reference point' and 
select the new reference point in the window 'Horizontal Map' 
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 The function will read the current chainage and coordinates of selected 
point. 

 Using the same dialogue box, type in the new chainage for selected point 
or alternatively, override the coordinates and chainage with known 
values. 

 

 

 Press OK button to accept changes. In case changes were made to the  
reference point coordinates only, the overall alignment chainage will not 
be affected.  

 The new reference point position will be marked with the a ´triangle´ 
symbol. 
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9.3.3 Workflow for manual vertical alignment and offsets adjustment 

 

The vertical alignment is automatically calculated together with horizontal alignment, either during GEDO 
track measurement data imported or at the re-calculation. Further, precise adjustment of the offsets can 
be done directly by editing the parameters for individual alignment elements: 

 for circular curve: radius, length, angular point elevation (PVI – point of vertical intersection), PVI 
chainage; 

 for gradient line: start/end point chainage and elevation. 

The vertical curve radius can be edited, either by changing the radius or its length. The correlation between 
curve radius R and length L is L=R*SD, where SD is change in grade along the vertical curve. 

Alternatively, the fixed element and PVI position can be adjusted using the mouse cursor. It is 
recommended to use Snap (F9) function , so the mouse cursor is locked to the measured points. 

 

Manually to adjust vertical elements and offsets, proceed as follows: 

 Identify the alignment location (or elements) where the vertical offsets are exceeding set limits or 
element parameter is incorrect. 

 Zoom in on the Diagram window or Vertical Map window, so the focus is over the area where 
vertical alignment offsets needs to be adjusted. 

 

 
 
  

Offset limits 
in cm 

Offsets from 
design in cm 

Offset 
adjustment 
area 

Design alignment = 
Vertical Offset ´0´ 
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 In the Vertical Map layout use the mouse right-click to select Normal (edit mode) command. When 
Normal (edit mode) command is activated, the mouse cursor follows the alignment and enables to 
select individual elements for detail editing. 

 

 

 

 Select element for editing by using the left mouse click. Selected element information is displayed 
in the Status bar. 

 

 

 

Note. 

It is recommended to start the adjustment of vertical offsets at the chainages where offsets are at their 
peak (above or below) the design alignment. 

 

 From the toolbar, select the function ´Insert angular point´ to insert an IP. Use the mouse left-click 
to select the element (chainage) where the angular (IP) point should be inserted. 

 

 
 
  

Activated 
element for 
editing 

Offset ´+´ 

Offset ´-´ 

New angular 
point location 
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 In the ´New vertical point´ dialogue box, chainage (STA) and elevation (Z) data is automatically 
extracted from the measured points. The default radius value is set to ´5000,0´ m. The circular 
curve length will be calculated based on the radius value and incoming/outgoing gradients. 

 

 
 

 Further, open the element editing dialogue by double clicking the element. Element editing dialog 
is transparent, so it´s stays active with selection of next element. 

 

 

Gradient element dialogue box 

 

Input data: fixed point chainage (STA) and elevation (Z) 

 

 

 

Vertical curve dialogue box 

 

Input data: element radius, length, PVI point chainage (STA) and 
elevation (Z) 

 

 

  

Activated 
element for 
editing 

Offset ´+´ 

Offset ´-´ 

New angular 
point and 
circular curve 
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 Adjust radius by typing manually between 3000 m and 5000 m, so the circular curve element is 
extended in length. Press ´Calculate´ to update changes. 

 Press Next element to continue with the adjustment of neighbouring element. Modify elevation, 
chainage or radius using the up/down arrows for each field. Whilst editing, alignment 
recalculation and offset update is done automatically. When values are entered directly, press 
´Calculate´ to update geometry and offsets. 

 If there are still residual offsets, switch to neighbouring element by pressing ´Next element´ or 
´Previous element´ button.  

 First minimize offsets by adjusting the elevation Z value, and then adjust the chainage for further 
offset reduction. 

 

Note. 

element radius/length modification has less of an impact to vertical offset; 

first adjust the PVI elevation and then adjust the radius/length; 

for Gradient – Gradient element connection use Radius of 1,0 meter; 

to accelerate the editing of PVI (angular) and fixed point chainages, use the mouse left key to select a fixed 
point and move in a chainage direction. It is recommended to activate AutoSnap (F9), so fixed points are 
following measured points. If AutoSnap is deactivated, fixed points can be moved unconstrained, in both 
chainage and elevation direction. 

 

 

 

  

Element constrain points 

Move fixed points along chainage to adjust 
element start/end chainage, length and radius 

Undo function 
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 When the PVI (angular) and fixed points are moved using mouse cursor, follow the status bar 
information about current point position and delta chainage/elevation from previous: 

 

 PVI (angular) point 

 

 Fixed point 

 

Important! 

the ´Undo´        function will undo all changes made after last project save; 

if an vertical alignment solution reports element overlap, press the ´Undo´        key to return parameter 
values to their previous state; 

´Circular curve´ elements can be deleted directly from element editing dialog, by pressing ´Delete element´ 
button; 

´Straight´ elements can be deleted from the Vertical Map view, by selecting element and pressing keyboard 
´DEL´ key. 
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9.3.4 Functions for vertical alignment editing 

9.3.4.1 Insert Vertical Angular Point (Intersection Point) 

 

Icon Function description 

 

To insert curves into a vertical alignment: 

 

 Activate the layout window 'Vertical Map'  

 From the toolbar run the function ´Insert Angular Point´ (INS key) 

 The program prompts for the curve insertion point. Use the mouse left-
click to insert a point or alternatively use ´INS´ key 

 The program will prompt with the dialogue box 'New Vertical Point' for the 
new curve settings (observe the status bar): 

 

 

 

 Click the button OK to calculate the new vertical alignment. If the 
calculation fails, the vertical alignment is to be edited by the user until the 
calculation is successful. 

 

9.3.4.2 Delete a Vertical Angular (Intersection Point) Point 

 

Icon Function description 

 

To delete a Vertical Angular (IP) Point. 

 

 Switch layout to ´Vertical Map´ 

 Select the vertical alignment angular element (curve) using mouse left-key. 
Selected element will be highlighted with a thicker line.  

 Press the Delete key to remove the marked element. 

 After deleting the angular element (curve), the start and end grading lines 
will be joined into one element. 

- Position of the vertical angular (IP) 
point (chainage). 

- Elevation of the curve. 

- Radius of curve. The default radius is 
5000.0m. 
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If the calculation fails after deleting a curve, the vertical alignment elements has to 
be edited until the calculation is successful. 
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 Calculation of cant and speed  

 

Software functionality allows you to calculate the recommended Cant and Speed values, by evaluating the 
complete alignment geometry, individual alignment elements and settings in the Calculation profile.  

Cant and speed values are recalculated automatically upon every change in the horizontal alignment and 
are shown in the table and diagram form. 

 

To review calculated speed a cant in a table view, proceed as follows: 

 From the main menu, select Tools -> Cant and Speed calculations… or double click Cant Diagram. 

 The function will open a new dialogue box, containing two tabs: 

 Given speed – speed limit marking in the Diagram view. 

 Speed – cant and speed calculation  

 

Note. 

All settings for the speed and cant calculation are accessible from the main menu Tools -> Options -> 
General -> Edit profile... Alternatively, the calculation settings and corresponding values can be edited in 
the profiles.ini file, located in the GEDO NovaTrack program directory. File format definition is listed in the 
Appendix 1. File formats.In the ´Speed´ tab, the ´grey´ and ´white´ fields are calculated automatically, 
however it is possible to override proposed values in the ´white´ fields. 

 

The table columns have the following meaning: 

Name Description Name Description 

Nr. Hor.alignment element number V Calc. Vmax speed based on element 

From Element start chainage h1 Element start Cant. Based on element group 

To Element end chainage h2 Element end Cant. Based on element group 

R1 Element start radius v Calc. Vmax speed based on element group 

R2 Element end radius K Select to override proposed values 

L Element length   

H1 Element start Cant value   

H2 Element end Cant value   
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 To store user defined cant and speed values in the ´h1´, ´h2´ and ´v´, select the checkbox in the 
column ´K´.  

 

 

 Press OK to store settings.  

 To evaluate speed calculations graphically, switch to the Diagram layout. Speed information is 
shown in the Speed (km/h) chart.  

 

  

Calculated Vmax for element 
(dotted line) 

User defined Vmax 
(colour coded) 

Calculated Vmax for element in 
a group (continues line) 
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 Calculation report data 

 

The software produces calculation reports based on horizontal alignment input and output results. The 
calculation log is automatically updated each time the horizontal alignment geometry is affected or after 
manual element editing.  

To access the calculation result log: 

 From the toolbar select icon  Show Result File or in the status bar double click message box 'Calc 
Ok’ / 'Calc not Ok’. 

 

 

 

 The input and calculation result data will be separated by two individual headings - ´Horizontal 
Alignment Input Data´ and ´Horizontal Alignment Main Points - Result´. 

 

  

 

Important! 

In the case the solution for horizontal alignment cannot be found within set constrains, the status bar 
indicates ´ Calc not Ok ´and Analysis Diagram is coloured in ´magenta´. Please check calculation Result file 
for possible errors in element connection. 
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To check result file for errors:  

 Open result file and scroll to the header ´Horizontal Alignment Main Points - Result´. 

Each element causing an error in the element connectivity and therefore preventing an alignment 
solution, has only a few parameters listed. The parameters which cannot be calculated are marked 
with error codes or are not listed at all. 

 Under the header ´Control and Error Messages´, check for the error records indicating faulty 
element and elements where calculation was aborted. 

  

Result protocol. 
Error detection in Element No.4 

Result protocol. 
Result after error in Element No.4 corrected. 

 

  

Analysis diagram. 
Error detection in Element No.4 

Analysis diagram. 
Result after error in Element No.4 corrected. 

 

Element No.4 (TC) is not 
fitting to el. 3 and 5.  

Length of element No.4 
(SL) was adjusted. 
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 Alignment geometry verification 

 

Each alignment recalculation and editing activity is automatically followed by alignment element 
verification against user defined settings. Settings for alignment element verification are defined and stored 
in the same table as Calculation settings. Please refer to the chapter Appendix 2. Calculation profile 
definition for more detail information 

To edit existing or to define new calculation profiles with alignment validation values, proceed as follows: 

 From the menu select Tools -> Option-> General and press button ´Edit profile…´. 

 To edit existing profile, select profile and edit appropriate values. 

 

 To delete profile, first select profile and then press ´Delete current profile´ button. 

 To create new profile, first select reference profile and then press ´ New (copy from existing) ´ 
button. All variable values will be transferred from reference profile to new profile and can be 
adjusted. 

 When profile editing is completed, press ´OK´ button to store changes.  

 

Note. 

For the complete list of alignment verification variables, please refer to the chapter ´Appendix 2. 
Calculation profile definition ´. 

 To apply new settings to active alignment and to run element validation, press ´Apply´ button. 
Validation process will be performed both for horizontal and vertical alignment. 

Alignment elements which do not correspond with set verification criteria are marked with warning  
symbol  .  

 To get rough validation, move mouse over warning  symbol. The status bar line will show primary 
issue with an element. 
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 To get more precise information with validating issues, double click the element. The element 
editing dialog will show ´highlighted´ parameter which is beyond the set criterial limits. 

 

 

 Once the element is adjusted (from the editing dialog or using Analysis Diagram) to comply with set 
requirements, warning information will be automatically removed. 

 
  

Element validation status 

Active element 

Warning sign highlighted 
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Appendix 1. File formats 

Trimble GEDO GTD file format (*.gtd)  
Data: track trajectory, cant, gauge 

Field delimiter: comma  

Decimal separator: dot  

Example: 
[Header] 

FormatVersion = 1.0   ; file format version 

Name = 34.6 to 38.5 140913  ; file name  

ReferenceGauge = 1.435  ; reference gauge 

CantBase = 1.5096   ; cant base 

[TrackData]   ; detail track data 

[Point_no;;E-coord_C(m);N-coord_C(m);H-elev_C(m);Gauge(m);Incl(rads);Chainage(m);Prism_side;Ref_H_Rail] 

34550R->34714L_1;;664538.782187441;7718601.40019557;45.8830243763602;1.434716544;-0.000818998017437332;34548.9312164998;Right;Left 

34550R->34714L_2;;664538.889472634;7718600.88728717;45.8840264333605;1.434628768;-0.00108607569285843;34549.9164060877;Right;Left 

34550R->34714L_3;;664539.108236682;7718599.73199802;45.8807265808121;1.434907288;-0.00118400417384616;34552.5435993232;Right;Left 

34550R->34714L_4;;664539.335100111;7718598.56973668;45.8854532262065;1.43510816;-0.00168254916796553;34552.985992017;Right;Left 

34550R->34714L_5;;664539.665681707;7718596.8885067;45.8919555278645;1.435060896;-0.00159352327615851;34553.919607927;Right;Left 

34550R->34714L_6;;664539.911129619;7718595.6141894;45.8842067348748;1.4338506;-0.00147778961680936;34556.3216059077;Right;Left 

34550R->34714L_7;;664540.305065043;7718593.62403868;45.8899238025968;1.434178072;-0.000925829087605769;34557.0148760155;Right;Left 

34550R->34714L_8;;664540.576357108;7718592.19784344;45.880942453584;1.435855944;-0.000605335877100458;34560.5892768363;Right;Left 

KOF file format (*.kof) 
Data: points, lines, alignments 

Field delimiter: space 

Decimal separator: dot 

Example: 

-00 FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF * 

-01 OOOOOOOOOOOO DDDDDDDDDDDD VVVVVVVVVVVV KKKKKKKKKKKK OOOO00000000 * 

-02 SSSSSSSSSS KKKKKKKK NNNNNNNN TTTTTTTT TTTTTTTT II.III Bk MMMMMMM * 

-03 TTTTTTTTTT KKKKKKKK HHH.HHHH VVV.VVVV AAAA.AAA SS.SSS Bk MMMMMMM * 

-04 TTTTTTTTTT KKKKKKKK HHH.HHHH DDDD.DDD AAAA.AAA SS.SSS Bk MMMMMMM * 

-05 PPPPPPPPPP KKKKKKKK XXXXXXXX.XXX YYYYYYY.YYY ZZZZ.ZZZ Bk MMMMMMM * 

-06 PPPPPPPPPP KKKKKKKK PPPPPPPP.PPP AAAAAAA.AAA ZZZZ.ZZZ Bk MMMMMMM * 

-09 FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF Pi MMMMMMM * 

 

-Pno   Chain. Fcode      N-coord. E-coord. H-Elev.  0         * 

 09_91  

 05 300        12700     6595748.607  163951.272   11.548 

 05 302        12700     6595748.473  163950.606   11.553 

 05 303        12700     6595748.425  163950.361   11.554 

 09_99  

 09_91  

 05 900        12701     6595749.483  163951.097   11.549 

 05 904        12701     6595749.249  163949.928   11.557 

 09_99  
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VER file format (*.ver) (Plasser & Theuer, offsets for tamping) 

Data: chainages, horizontal and vertical offsets 

Field delimiter: space 

Decimal separator: dot 

Example: 

VerschHoehen         1.0Vorw___ ====EndOfFileHeader=== 

========= BeginOfTab ========= 

  15202.000  -1.062e+000   1.448e+001   0.000e+000 

  15204.000  -7.132e-001   9.719e+000   0.000e+000 

  15206.000  -5.048e-001   4.378e+000   0.000e+000 

  15208.000  -1.076e+000   6.838e-001   0.000e+000 

========== EndOfTab ========== 

 

 

GEO file format (*.geo) (Plasser & Theuer, alignment for tamping) 

Data: chainages, horizontal and vertical alignments 

Field delimiter: space 

Decimal separator: dot 

Example: 

SollGeom             1.0Vorw___ ====EndOfFileHeader=== 

========= BeginOfTab ========= 

  15200.000  -0.000e+000   0.000e+000  449  464 

  15200.000  -0.000e+000   0.000e+000  449  464 

  15289.523   6.600e+001   6.600e+001  451  465 

  15355.523   6.040e+002   0.000e+000  450  464 

  15698.343   6.800e+001   6.800e+001  451  465 

  15766.343  -0.000e+000   0.000e+000  449  464 

  15869.050   7.800e+001   7.800e+001  451  465 

========== EndOfTab ========== 

 

LIN file format  (*.lin) 

Data: horizontal alignment 

Field delimiter: comma 

Decimal separator: dot 

Example: 
6 

1,5526944.08450,4366033.85216,  15200.00000,      0.00000,124.537926,      0.00000,      0.00000,     89.52254, 

2,5526910.42692,4366116.80667,  15289.52254,      0.00000,124.537925,    199.65970,   -604.00000,     65.99999, 

3,5526886.73403,4366178.39799,  15355.52253,   -604.00000,121.059705,      0.00000,   -604.00000,    342.82051, 

4,5526870.83824,4366516.26160,  15698.34304,   -604.00000, 84.926209,    202.66226,      0.00000,     67.99999, 

5,5526889.25546,4366581.71007,  15766.34303,      0.00000, 81.342589,      0.00000,      0.00000,    102.70668, 
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GPS file format (*.gps) 

Data: points 

Field delimiter: space 

Decimal separator: comma 

Example: 

 
1 4366118,24909854 5526911,24741448 277,69031134 

2 4366120,10299811 5526910,49704092 277,72766083 

3 4366121,95690843 5526909,74669538 277,76451828 

4 4366123,80934050 5526908,99271899 277,80215430 

5 4366125,66213876 5526909,23962918 277,83786697 

6 4366127,51624900 5526910,48978106 277,87329802 

7 4366129,36890285 5526915,73633363 277,90791061 

8 4366131,22185912 5526914,98364677 277,94311873 

9 4366133,07479519 5526914,23088918 277,97703579 

10 4366134,92729626 5526918,47707744 278,01101642 

11 4366136,78144995 5526910,72732526 278,04613538 

12 4366138,63572410 5526917,97787617 278,08146977 

 
 
LandXML file format – Import (*.xml) 

Data: points 

Field delimiter: not applicable 

Decimal separator: not applicable 

Example: 

 
<?xml version="1.0" encoding="utf-8"?> 

<LandXML xmlns="http://www.landxml.org/schema/LandXML-1.2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 

xsi:schemaLocation="http://www.landxml.org/schema/LandXML-1.2 http://www.landxml.org/schema/LandXML-1.2/LandXML-

1.2.xsd" version="1.2" date="2019-08-29" time="15:52:45" readOnly="false" language="English"> 

  <Project name="" desc=""> 

    <Feature name="projectExt"> 

      <Property label="id" value="8fd6e5a57b6e41ff9523b7a7f91a8342" /> 

    </Feature> 

    <Feature code="trimbleLayers"> 

      <Feature code="trimbleLayer"> 

        <Property label="name" value="Points" /> 

        <Property label="color" value="255,255,255" /> 

        <Property label="lineStyleName" value="Solid" /> 

        <Property label="lineWeight" value="0" /> 

      </Feature> 

    </Feature> 

  </Project> 

  <Units> 

    <Metric linearUnit="meter" widthUnit="meter" heightUnit="meter" diameterUnit="meter" areaUnit="squareMeter" 

volumeUnit="cubicMeter" temperatureUnit="celsius" pressureUnit="HPA" angularUnit="decimal degrees" 

directionUnit="decimal degrees" /> 

  </Units> 

  <Application name="Trimble Business Center" manufacturer="Trimble" version="31.0.7088.19172" timeStamp="2019-08-

29T15:52:45"> 

    <Author createdBy="Lmaciul" timeStamp="2019-08-29T15:52:45" /> 

  </Application> 

  <CgPoints> 

    <CgPoint name="IX_track_points_10m_2_1" featureRef="Points">5065125.54200 465821.32800 63.05700</CgPoint> 

    <CgPoint name="IX_track_points_10m_2_2" featureRef="Points">5065115.08200 465821.26300 62.97800</CgPoint> 

    <CgPoint name="IX_track_points_10m_2_3" featureRef="Points">5065135.82900 465821.24000 63.14100</CgPoint> 

    <CgPoint name="IX_track_points_10m_2_4" featureRef="Points">5065108.57600 465821.15400 62.92700</CgPoint> 

    <CgPoint name="IX_track_points_10m_2_5" featureRef="Points">5065145.90100 465821.00600 63.21300</CgPoint> 

    <CgPoint name="IX_track_points_10m_2_6" featureRef="Points">5065098.38100 465820.83800 62.84500</CgPoint> 

    <CgPoint name="IX_track_points_10m_2_7" featureRef="Points">5065156.38900 465820.65100 63.30200</CgPoint> 

    <CgPoint name="IX_track_points_10m_2_8" featureRef="Points">5065088.34800 465820.38300 62.76500</CgPoint> 

    <CgPoint name="IX_track_points_10m_2_9" featureRef="Points">5065166.22700 465820.22000 63.39100</CgPoint> 

  </CgPoints> 

</LandXML> 
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LandXML file format – Export (*.xml) 

Data: horizontal/vertical alignment geometry 

Field delimiter: not applicable 

Decimal separator: not applicable 

Example: 

 
<?xml version="1.0" encoding="utf-8"?> 

<LandXML xsi:schemaLocation="http://www.landxml.org/schema/LandXML-1.1 http://www.landxml.org/schema/LandXML-1.1/LandXML-1.1.xsd" 

date="2019-08-29" time="13:54:43+02:00" version="1.1" xmlns="http://www.landxml.org/schema/LandXML-1.1" 

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 

 <Units> 

  <Metric areaUnit="squareMeter" linearUnit="meter" volumeUnit="cubicMeter" temperatureUnit="celsius" 

pressureUnit="mmHG" angularUnit="radians" directionUnit="radians"/> 

 </Units> 

 <Application name="NovaTrack" manufacturer="Trimble Railway GmbH" version="2.0.1 (822)" manufacturerURL="www.trimble-

railway.com"> 

  <Author createdBy="User1"/> 

 </Application> 

 <Project name=""/> 

 <Alignments name=""> 

  <Alignment name="From NovaTrack" staStart="0.000000" length="4551.273194"> 

   <CoordGeom> 

    <Line staStart="0.000000" length="191.457445" dir="3.090229"> 

     <Start>6065346.847000 465808.873000</Start> 

     <End>6065155.642053 465818.702624</End> 

    </Line> 

    <Spiral staStart="191.457445" constant="156.000" radiusStart="INF" radiusEnd="467.000000" 

spiType="clothoid" length="52.111349" rot="cw" dirStart="3.089971" dirEnd="3.145764"> 

     <Start>6065155.642053 465818.702624</Start> 

     <PI>6065120.941312 465820.486549</PI> 

     <End>6065103.565881 465820.409574</End> 

    </Spiral> 

    <Curve staStart="243.568794" rot="cw" length="88.439274" radius="467.000000" 

chord="88.307176" dirStart="3.145764" dirEnd="3.335981"> 

     <Start>6065103.565881 465820.409574</Start> 

     <Center>6065105.634737 465353.414157</Center> 

     <End>6065015.692139 465811.670994</End> 

    </Curve> 

    <Spiral staStart="332.008068" constant="78.000" radiusStart="467.000000" radiusEnd="INF" 

spiType="clothoid" length="13.027837" rot="cw" dirStart="3.335981" dirEnd="3.349349"> 

     <Start>6065015.692139 465811.670994</Start> 

     <PI>6065011.430749 465810.834606</PI> 

     <End>6065002.932204 465809.043133</End> 

    </Spiral> 

    <Line staStart="345.035905" length="33.253699" dir="3.349349"> 

     <Start>6065002.932204 465809.043133</Start> 

     <End>6064970.393585 465802.184069</End> 

    </Line> 

    <Spiral staStart="378.289604" constant="84.000" radiusStart="INF" radiusEnd="501.000000" 

spiType="clothoid" length="14.083833" rot="cw" dirStart="3.348763" dirEnd="3.363404"> 

     <Start>6064970.393585 465802.184069</Start> 

     <PI>6064961.206172 465800.247384</PI> 

     <End>6064956.626491 465799.214563</End> 

    </Spiral> 

    <Curve staStart="392.373437" rot="cw" length="88.586484" radius="501.000000" 

chord="88.471127" dirStart="3.363404" dirEnd="3.540481"> 

     <Start>6064956.626491 465799.214563</Start> 

     <Center>6065066.845151 465310.488825</Center> 

     <End>6064872.378444 465772.207029</End> 

    </Curve> 

    <Spiral staStart="480.959921" constant="167.000" radiusStart="501.000000" radiusEnd="INF" 

spiType="clothoid" length="55.666667" rot="cw" dirStart="3.540481" dirEnd="3.595779"> 

     <Start>6064872.378444 465772.207029</Start> 

     <PI>6064855.272741 465765.002440</PI> 

     <End>6064821.918629 465748.717993</End> 

    </Spiral> 

    <Line staStart="536.626588" length="257.162205" dir="3.595779"> 

     <Start>6064821.918629 465748.717993</Start> 

     <End>6064590.827995 465635.892824</End> 

    </Line> 

    <Spiral staStart="793.788793" constant="227.000" radiusStart="INF" radiusEnd="681.000000" 

spiType="clothoid" length="75.666666" rot="ccw" dirStart="3.595779" dirEnd="3.540224"> 

     <Start>6064590.827995 465635.892824</Start> 

     <PI>6064545.490370 465613.757677</PI> 

     <End>6064522.238905 465603.964613</End> 

   </CoordGeom> 

   <Profile staStart="0.000000"> 

    <ProfAlign name="From NovaTrack"> 

     <PVI>0.000000 64.327000</PVI> 

     <CircCurve length="5803.772065" radius="19.999653">117.482044 63.868000</CircCurve> 

     <CircCurve length="17619.465580" radius="19.999369">238.655032 

62.977000</CircCurve> 

     <CircCurve length="49377.012293" radius="19.999244">583.011244 

60.054000</CircCurve> 

     <CircCurve length="-9319.133311" radius="19.999377">758.759932 

58.491000</CircCurve> 

     <CircCurve length="-2894.169894" radius="19.999772">1085.862110 

56.284000</CircCurve> 

     <CircCurve length="-29449.176512" radius="19.999996">1349.032818 

56.327000</CircCurve> 

     <CircCurve length="-9677.417063" radius="19.999954">1927.054907 

56.814000</CircCurve> 

     <CircCurve length="-17774.090069" radius="19.999876">2056.987410 

57.192000</CircCurve> 

     <CircCurve length="7511.580248" radius="19.999909">2258.997610 

58.007000</CircCurve> 
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     <CircCurve length="-3371.480888" radius="19.999724">2627.835957 

58.513000</CircCurve> 

     <CircCurve length="47250.286616" radius="19.999497">2893.577200 

60.454000</CircCurve> 

     <CircCurve length="4730.701206" radius="19.999728">2999.088210 

61.180000</CircCurve> 

     <CircCurve length="27378.521810" radius="19.999946">3445.752466 

62.365000</CircCurve> 

     <CircCurve length="-5547.843172" radius="19.999829">3741.201724 

62.933000</CircCurve> 

     <CircCurve length="3683.032329" radius="19.999847">4110.081210 

64.972000</CircCurve> 

     <CircCurve length="60998.297990" radius="20.000000">4521.605683 

65.012000</CircCurve> 

     <PVI>4551.950955 65.005000</PVI> 

    </ProfAlign> 

   </Profile> 

  </Alignment> 

 </Alignments> 

</LandXML>  
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Appendix 2. Calculation profile definition 

 

List of user defined calculation variables 

 

Calculation profile header 

 

 

[TRACK_CAT_2] Profile header (name) 

description=Profile description Profile description 

created_by=User1 Created by name or initials 

 

HA Alignment regression variables 

 

 

analyse_method=2 Selected analysis method 

error_tolerance=5.0 Error tolerance for horizontal geometry (m) 

error_tolerance_vertical=0.2 Error tolerance for vertical geometry (m) 

error_tolerance_offset_pnts=85 Minimum % of measured points on resulting alignment 

(%) 

nt3_remove_split=97 Initial percentage value for removing split points 

(%) 

nt3_remove_split_step=3 Step size when iterating 

nt3_remove_split_lines=7 Remove split point if less measure points than 

number since previous split point 

nt3_merge_split_segments=0.2 Merge split points id tolerance is below value 

min_straight_line=50.0 Minimum length of straight line in result alignment 

min_radius_for_trans_curves=500.0 Minimum radius when inserting transition curves (m) 

min_lift=0.100 Minimum vertical lift for vertical geometry (m) 

number_of_iterations=1 Number of iterations. Set to 1 to disable. 

 

VA Alignment calculation variables 

 

 

error_tolerance_vertical=0.2 Error tolerance for vertical geometry (m) 

min_lift=0.100 Minimum vertical lift for vertical geometry (m) 

 

CANT and SPEED calculation variables 

 

 

hmax=130 Maximum cant value (mm) 

a=1.05 Minimum length for element with constant curvature 

(0.5V) (normal) 

n=400 Maximum value for Cant change ratio (1:n) 

Imax=9999999.0  160 Maximum values for Cant deficiency @ R 

ImaxKP=100 Maximum Cant for circular curves 

dImax=100 Maximum value for Cant variation 

dDmax=9999999.0  69 Limit value for Cant ramp incline speed 

Emax=600.0  90  9999999.0  110 Limit value for Cant Excess @ R 

Vg=80 Maximum speed of the freight trains, km/h 

b=0.5 Minimum length for element with constant curvature 

(0.25V) (minimum) 

c=2.6 Coefficient for Rv calculation (2.6 normal, 3.6 

minimum) 

Vmax=200 Maximum speed (km/h) 

 

GEOMETRY verification variables 

 

 

CRmin=500 Minimum radius for curve (m) 

CRmax=5000 Maximum radius for curve (m) 

SLCmin=0.25 Minimum Straight line length between two Circular 

curves 

CLmin=20 Minimum length for curve (m) 

TCLMin=0.5 Minimum length transition curve (m) 

RminTCmin=300.0 40.0 400.0 45.0 500.0 50.0 Minimum Transition curve length @ radius 

VCRmax=70000.0 Maximum vertical crest radius (m) 

VSRmax=70000.0 Maximum vertical sag radius (m) 

VELmin=10 Minimum vertical element length (m) 

VESmax=10 Maximum vertical element slope (per-mille, ‰) 
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Calculation profile settings(profiles.ini) 

 

Example: 

;**************************************************************** 

 [New tracks smoothing] 

 description=This is the description for new tracks 

 created_by=AB 

;Selected analyse method 

 analyse_method=1 

;Error tolerance for horizontal geometry (m) 

 error_tolerance=5.000 

;Error tolerance for vertical geometry (m) 

 error_tolerance_vertical=0.2 

;Minimum % of measured points on resulting alignment (%) 

 error_tolerance_offset_pnts=85 

;Initial percentage value for removing split points (%) 

 nt3_remove_split=97 

;Step size when iterating 

 nt3_remove_split_step=3 

;Remove split point if less measure points than number since previous split point 

 nt3_remove_split_lines=7 

;Merge split points id tolerance is below value 

 nt3_merge_split_segments=0.2 

;Minimum length of straight line in result alignment 

 min_straight_line=10.000 

;Minimum radius when inserting transition curves (m) 

 min_radius_for_trans_curves=500.000 

;Minimum vertical lift for vertical geometry (m) 

 min_lift=0.100 

;Number of iterations. Set to 1 to disable. 

 number_of_iterations=1 

;Maximum cant value (mm) 

 hmax=150 

;Minimum length for element with constant curvature (0.5V) (normal) 

 a=0.5 

;Maximum value for Cant change ratio (1:n) 

 n=400 

;Maximum values for Cant deficiency @ R 

 Imax=600.0  80  9999999.0  100 

;Maximum Cant for circular curves 

 ImaxKP=100 

;Maximum value for Cant variation 

 dImax=25 

;Limit value for Cant ramp incline speed 

 dDmax=999999.0 28 

;Limit value for Cant Excess @ R 

 Emax=600.0  50  9999999.0  70 

;Maximum speed of the freight trains, km/h 

 Vg=80 

;Minimum length for element with constant curvature (0.25V) (minimum) 

 b=0.5 

;Coefficient for Rv calculation (2.6 normal, 3.6 minimum) 

 c=2.6 

;Maximum speed (km/h) 

 Vmax=200 

;Minimum radius for curve (m) 

 CRmin=500 

;Maximum radius for curve (m) 

 CRmax=5000 

;Minimum Straight line length between two Circular curves 

 SLCmin=0.25 

;Minimum length for curve (m) 

 CLmin=20 

;Minimum length transition curve (m) 

 TCLMin=0.5 

;Minimum Transition curve length @ radius 

 RminTCmin=300.0 40.0 400.0 45.0 500.0 50.0 
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;Maximum vertical crest radius (m) 

 VCRmax=70000.0 

;Maximum vertical sag radius (m) 

 VSRmax=70000.0 

;Minimum vertical element length (m) 

 VELmin=10 

;Maximum vertical element slope (per-mille, ‰) 

 VESmax=10 

;************************************************************* 
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Document revisions 

 

Rev. no. Date Latest changes User 

1.0.1. 15.01.2018 First release LM 

2.0.0. 01.03.2019 Second release LM 

2.0.1. 02.09.2019 Third release. Support for US Feet 
units. 

LM 
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Notes. 
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